Login | Register
My pages Projects Community openCollabNet

Discussions > users > Re: perl::critic installation

perlcritic
Discussion topic

Back to topic list

Re: perl::critic installation

Author Elliot Shank <perl at galumph dot com>
Full name Elliot Shank <perl at galumph dot com>
Date 2008-07-21 08:08:35 PDT
Message 陈佩秀 June T. wrote:
> I am having a slight problem trying to install perl::critic, and was
> wondering if you could please help me. I have already installed the
> Exception::Class and the PPI modules, but for some reason, the program
> can't find it. I have added my home /lib directory to @INC, but it's
> still having problems. I tried searching on the internet, but I
> couldn't find anything, so I was wondering if you could please help
> me...
>
> Thank you
> June
>
>
> [~/Perl-Critic-1.088]$ perl Makefile.PL PREFIX=~/lib LIB=~/lib
> Warning: prerequisite Exception::Class 1.23 not found.
> Warning: prerequisite PPI 1.203 not found.
> Warning: prerequisite PPI::Document 1.203 not found.
> Warning: prerequisite PPI::Document::File 1.203 not found.
> Warning: prerequisite PPI::Node 1.203 not found. We have unknown version.
> Warning: prerequisite PPI::Token::Quote::Single 1.203 not found.
> Warning: prerequisite PPI::Token::Whitespace 1.203 not found.
> Writing Makefile for Perl::Critic
>
> Versions of optional/unlisted/indirect dependencies:
>
> File::HomeDir = not installed
> File::Which = not installed
> IPC::Open2 = 1.02
> Perl::Tidy = not installed
> Pod::Spell = not installed
> Readonly::XS = not installed
> Regexp::Parser = not installed
> Term::ANSIColor = 1.10
> Text::ParseWords = 3.24

What's the output of "perl -V"?

« Previous message in topic | 1 of 1 | Next message in topic »

Messages

Show all messages in topic

Re: perl::critic installation Elliot Shank <perl at galumph dot com> Elliot Shank <perl at galumph dot com> 2008-07-21 08:08:35 PDT
Messages per page: