Login | Register
My pages Projects Community openCollabNet

Discussions > users > What should I name a policy for a CPAN module?

perlcritic
Discussion topic

Back to topic list

What should I name a policy for a CPAN module?

Author flimm
Full name David D Lowe
Date 2014-11-27 08:04:51 PST
Message I have implemented a PerlCritic policy that checks for some common gotchas with Try::Tiny. What should I name it, considering it's not a Perl core module?

I've been thinking of:

Perl::Critic::Policy​::CPAN::TryTiny
Perl::Critic::Policy​::CPAN::Try::Tiny
Perl::Critic::Policy​::CPAN::Try::Tiny::R​equireCatch

I couldn't find any other examples to copy.

Any ideas?

- David D Lowe

« Previous message in topic | 1 of 5 | Next message in topic »

Messages

Show all messages in topic

What should I name a policy for a CPAN module? flimm David D Lowe 2014-11-27 08:04:51 PST
     Re: What should I name a policy for a CPAN module? thaljef Jeffrey Ryan Thalhammer 2014-11-30 19:12:43 PST
         Re: What should I name a policy for a CPAN module? thaljef Jeffrey Ryan Thalhammer 2014-11-30 20:48:14 PST
             Re: What should I name a policy for a CPAN module? flimm David D Lowe 2014-12-03 07:20:27 PST
     Re: What should I name a policy for a CPAN module? jonasbn Jonas B. Nielsen 2014-11-30 23:41:52 PST
Messages per page: